$re = '/\a|def|xyz|abc/';
$str = 'I wish to know if a string contains one of "abc" "def" "xyz", etc, I could do it like';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);