import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\. )([A-Z])";
final String string = "Deus abencoou Noe e seus filhos, e lhes disse: \"Sede fecundos, multiplicai-vos, enchei a terra. Sede o medo e o pavor de todos os animais da terra e de todas as aves do ceu, como de tudo o que se move na terra e de todos os peixes do mar: eles sao entregues nas vossas maos. Tudo o que se move e possui a vida vos servira de alimento, tudo isso eu vos dou, como vos dei a verdura das plantas. Mas nao comereis a carne com sua alma, isto e, o sangue. Pedirei contas porem, do sangue de cada um de vos. Pedirei contas a todos os animais e ao homem, aos homens entre si, eu pedirei contas da alma do homem. Quem derrama o sangue do homem pelo homem terra seu sangue derramado. Pois a imagem de Deus o homem foi feito. Quanto a vos, sede fecundos, multiplicai-vos, povoai a terra e dominai-a";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}