const regex = /(?<=\. )([A-Z])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\. )([A-Z])', 'g')
const str = `Deus abencoou Noe e seus filhos, e lhes disse: "Sede fecundos, multiplicai-vos, enchei a terra. Sede o medo e o pavor de todos os animais da terra e de todas as aves do ceu, como de tudo o que se move na terra e de todos os peixes do mar: eles sao entregues nas vossas maos. Tudo o que se move e possui a vida vos servira de alimento, tudo isso eu vos dou, como vos dei a verdura das plantas. Mas nao comereis a carne com sua alma, isto e, o sangue. Pedirei contas porem, do sangue de cada um de vos. Pedirei contas a todos os animais e ao homem, aos homens entre si, eu pedirei contas da alma do homem. Quem derrama o sangue do homem pelo homem terra seu sangue derramado. Pois a imagem de Deus o homem foi feito. Quanto a vos, sede fecundos, multiplicai-vos, povoai a terra e dominai-a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}