$re = '/^\$?([-A-Z0-9_ ]+)/m';
$str = 'ABC 123 123 534
$DEF564 456 5454';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);