#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)foo\.[ab]\s*=[\s\S]*?(?=foo\.[ab]\s*=)"
Local $sString = "foo.a = [10" & @CRLF & _
"20" & @CRLF & _
"30" & @CRLF & _
"40];" & @CRLF & _
"" & @CRLF & _
"foo.b = 'foobar';"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")