re = /foo\.[ab]\s*=[\s\S]*?(?=foo\.[ab]\s*=)/m
str = 'foo.a = [10
20
30
40];
foo.b = \'foobar\';'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end