package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:\d+(?:\.\d+)?(?:\s+\d+(?:\.\d+)?)*)?\s*[-+*/$£])`)
var str = `4.0 5.0 2.0 / + 7.0 - 11.0 34.0 2.0 / 3.0 / 1.0 * +`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}