re = /((?:\d+(?:\.\d+)?(?:\s+\d+(?:\.\d+)?)*)?\s*[-+*\/$£])/
str = '4.0 5.0 2.0 / + 7.0 - 11.0 34.0 2.0 / 3.0 / 1.0 * +'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end