$re = '/^ (?: aa (?= (?:aa)* (\1?+ b) ) )+ \1 $/mx';
$str = 'ab
aabb
aaaabbbb
aab
aaaabb
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);