$re = '/^([\da-zA-Z]+|[\da-zA-Z]*\*[\da-zA-Z]*)$
/m';
$str = 'Matches
*
abc
*abc
abc*
a*bc
Invalid Matches
**
*_abc
*abc*
abc**
**abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);