re = /^([\da-zA-Z]+|[\da-zA-Z]*\*[\da-zA-Z]*)$
/m
str = 'Matches
*
abc
*abc
abc*
a*bc
Invalid Matches
**
*_abc
*abc*
abc**
**abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end