import re
regex = re.compile(r"(?<=https://www.facebook.com/groups/).*?(?=/)")
test_str = "a href=\"https://www.facebook.com/groups/366139636814727/871873746241311/?comment_id=871905166238169&ref=notif¬if_t=group_comment\" class=\"_33e\" data-reactid=\".3.0.0.0.0.0.$100000241272846=21446664199525942.0.0\"><div class=\"clearfix\" data-reactid=\".3.0.0.0.0.0.$100000241272846=21446664199525942.0.0.0\"><d"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")