using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Job Title: ([A-Z]\w* [A-Z]\w*(?: [A-Z]\w*)?)";
string input = @"Job Title: Some Word Here
Job Title: Some Word";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}