$re = '/Job Title: ([A-Z]\w* [A-Z]\w*(?: [A-Z]\w*)?)/';
$str = 'Job Title: Some Word Here
Job Title: Some Word';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);