package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Job Title: ((?: *[A-Z]\w+){2,3})`)
var str = `Job Title: Some Word Here AndThere
Job Title: Some Sq`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}