using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Job Title: ((?: *[A-Z]\w+){2,3})$";
string input = @"Job Title: Some Word Here AndThere
Job Title: Some Sq
Job Title: Some Sq
Job Title: Some Sq";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}