$re = '/Job Title: ((?: *[A-Z]\w+){2,3})$/m';
$str = 'Job Title: Some Word Here AndThere
Job Title: Some Sq
Job Title: Some Sq
Job Title: Some Sq';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);