package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\+?\d{2,3}\s\d{3}\-\d{3}\-\d{3})$`)
var str = `+00 000-000-000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}