$re = '/^(\+?\d{2,3}\s\d{3}\-\d{3}\-\d{3})$/';
$str = '+00 000-000-000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);