using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^total kB\s+\d+\s+\K\d+";
string input = @"total kB 168194812 870692 852296";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}