$re = '/^total kB\s+\d+\s+\K\d+/m';
$str = 'total kB 168194812 870692 852296';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);