import re
regex = re.compile(r"(?P<nodeOpen><a:(?P<nodeName>.*)>)(?P<data>.*)(?P<nodeClose><\/a:(?P=nodeName)>)", flags=re.DOTALL)
test_str = ("<a:b>\n"
" <a:c></a:c>\n"
" <a:c></a:c>\n"
"</a:b>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")