re = /(?P<nodeOpen><a:(?P<nodeName>.*)>)(?P<data>.*)(?P<nodeClose><\/a:(?P=nodeName)>)/
str = '<a:b>
<a:c></a:c>
<a:c></a:c>
</a:b>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end