re = /^(?:https?:\/\/)?(?:www\.)?(?:youtu\.be\/|youtube\.com\/(?:embed\/|v\/|watch\?v=|watch\?.+&v=))((\w|-){11})(?:\S+)?$/
str = 'kolla in den här!! https://www.youtube.com/watch?v=eX2qFMC8cFo'
# Print the match result
str.match(re) do |match|
puts match.to_s
end