$re = '/content\s+=\'([^\']+?)\'\s+class\s+=\'([^\']+)\'/';
$str = 'test string [% code content =\'test content\' class =\'myclass\' %]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);