re = /content\s+='([^']+?)'\s+class\s+='([^']+)'/
str = 'test string [% code content =\'test content\' class =\'myclass\' %]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end