# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[[Video:(http)\:\/\/[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,3}(\/\S*)?4"
test_str = (" <p class=\"arttxt_tit\">ARTBLOG YAZARIMIZ OLUN! ekavArtblog</p>\n"
" <p class=\"arttxt\"><i>22.11.2011</i></p>\n"
" <p class=\"arttxt\">\n"
" <p style=\"text-align: center;\">\n"
" <br />\n"
" <img alt=\"\" src=\"http://www.ekavart.tv/handlers/Image.ashx?id=984\" style=\"width: 364px; height: 272px;\" /><br />\n"
" <br />\n"
" <br />\n"
" Sanatla ilgili her türlü yazınısı bizle paylaşın, yayınlayalım.<br />\n"
" <br />\n"
" Yazılarınızı, iletişim bilgilerinizle beraber info@ekavart.tv adresine en az 5 görselle gönderebilirsiniz.</p>\n"
"[[Video:http://data.ekavart.tv/ekav/temp/mp4/2016/7/13/3061.mp4\n"
" </p>\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.