re = /[[Video:(http)\:\/\/[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,3}(\/\S*)?4/
str = ' <p class="arttxt_tit">ARTBLOG YAZARIMIZ OLUN! ekavArtblog</p>
<p class="arttxt"><i>22.11.2011</i></p>
<p class="arttxt">
<p style="text-align: center;">
<br />
<img alt="" src="http://www.ekavart.tv/handlers/Image.ashx?id=984" style="width: 364px; height: 272px;" /><br />
<br />
<br />
Sanatla ilgili her türlü yazınısı bizle paylaşın, yayınlayalım.<br />
<br />
Yazılarınızı, iletişim bilgilerinizle beraber info@ekavart.tv adresine en az 5 görselle gönderebilirsiniz.</p>
[[Video:http://data.ekavart.tv/ekav/temp/mp4/2016/7/13/3061.mp4
</p>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end