import re
regex = re.compile(r"(?<=Zeus_Web_Version = )\d.[^\s]+")
test_str = ("\n"
"d:\\jenkins\\workspace\\ZeusWeb-Deploy>echo Zeus_Web_Version = 2.14.0.1732 \n"
"Zeus_Web_Version = 2.14.0.1732\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")