#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(G1:k6YxekrAP71LqRv)\[(?:S:(?:\d,)+\d\|)?(P:3)(?:\|R:(?:\d,)+\d)?\]"
Local $sString = "G1:k6YxekrAP71LqRv[P:3]" & @CRLF & _
"G1:k6YxekrAP71LqRv[S:2,3,4|P:3]" & @CRLF & _
"G1:k6YxekrAP71LqRv[P:3|R:2,3,4,5]" & @CRLF & _
"G1:k6YxekrAP71LqRv[S:2,3,4|P:3|R:2,3,4,5]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")