import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(G1:k6YxekrAP71LqRv)\\[(?:S:(?:\\d,)+\\d\\|)?(P:3)(?:\\|R:(?:\\d,)+\\d)?\\]";
final String string = "G1:k6YxekrAP71LqRv[P:3]\n"
+ "G1:k6YxekrAP71LqRv[S:2,3,4|P:3]\n"
+ "G1:k6YxekrAP71LqRv[P:3|R:2,3,4,5]\n"
+ "G1:k6YxekrAP71LqRv[S:2,3,4|P:3|R:2,3,4,5]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}