$re = '/(.+) ([IVXLC]*)(?: \(.+\))? (?:- Moon (\d+) )?- (Doomheim|Pann\'s Peeps|Polaris Bug Hunters|Polaris Corporation|Polaris Events|24th Imperial Crusade|Amarr Certified News|Amarr Civil Service|Amarr Constructions|Amarr Navy|Amarr Templars|Amarr Trade Registry|Ametat Security|Ardishapur Family|Bragian Order|Carthum Conglomerate|Civic Court|Company of Marcher Lords|Court Chamberlain|Ducia Foundry|Emperor Family|Fraternity of St\. Venefice|Further Foodstuffs|Hedion University|Holdfast Syndicate|HZO Refinery|Imperial Academy|Imperial Armaments|Imperial Chancellor|Imperial Guard|Imperial Shipment|Inherent Implants|Joint Harvesting|Kador Family|Kameira Lodge|Kor-Azor Family|Ministry of Assessment|Ministry of Internal Order|Ministry of War|Noble Appliances|Nurtura|Paladin Survey Force|Red and Silver Hand|Royal Amarr Institute|Royal Uhlans|Sarum Family|Shining Flame|Tal-Romon Legion|Tash-Murkon Family|Theology Council|Viziam|Zoar and Sons|Ammatar Consulate|Ammatar Fleet|Nefantar Miner Association|Archangels|Dominations|Guardian Angels|Salvation Angels|Blood Raiders|Caldari Business Tribunal|Caldari Constructions|Caldari Funds Unlimited|Caldari Navy|Caldari Provisions|Caldari Steel|CBD Corporation|CBD Sell Division|Chief Executive Panel|Commando Perkone|Corporate Police Force|Deep Core Mining Inc\.|Echelon Entertainment|Expert Distribution|Expert Housing|Expert Intervention|Home Guard|House of Records|Hyasyoda Corporation|Ikomari-Onu Enforcement|Intara Direct Action|Internal Security|Ishukone Corporation|Ishukone Watch|Isuuaya Tactical|Kaalakiota Corporation|Kinsho Swords|Kirkinen Risk Control|Lai Dai Corporation|Lai Dai Protection Service|Mercantile Club|Minedrill|Modern Finances|Nugoeihuvi Corporation|Onikanabo Brigade|Osmon Surveillance|Peace and Order Unit|Perkone|Poksu Mineral Group|Prompt Delivery|Propel Dynamics|Rapid Assembly|School of Applied Knowledge|Science and Trade Institute|Seituoda Taskforce Command|Spacelane Patrol|State and Region Bank|State Peacekeepers|State Protectorate|State War Academy|Storm Wind Strikeforce|Sukuuvestaa Corporation|Templis Dragonaurs|Top Down|Wiyrkomi Corporation|Wiyrkomi Peace Corps|Ytiri|Zainou|Zero-G Research Firm|Zumari Force Projection|CONCORD|DED|Inner Circle|Secure Commerce Commission|Vigilant Tyrannos|Algintal Core|Aliastra|Allotek Industries|Astral Mining Inc\.|Bank of Luminaire|Center for Advanced Studies|Chatelain Rapid Response|Chemal Tech|Combined Harvest|Condotta Rouvenor|CreoDron|Crux Special Tasks Group|Duvolle Laboratories|Edimmu Warfighters|Egonics Inc\.|Federal Administration|Federal Defense Union|Federal Freight|Federal Intelligence Office|Federal Marines|Federal Navy Academy|Federation Customs|Federation Navy|FedMart|Garoun Investment Bank|Impetus|Inner Zone Shipping|Kang Lo Directorate|Mannar Focused Warfare|Material Acquisition|Namtar Elite|Ostrakon Agency|Pend Insurance|Poteque Pharmaceuticals|President|Quafe Company|Resheph Interstellar Strategy|Roden Shipyards|Senate|Sinq Laison Gendarmes|Supreme Court|The Scope|TransStellar Shipping|University of Caille|Villore Sec Ops|Guristas|Guristas Production|Academy of Aggressive Behaviour|Genolution|Impro|Jove Navy|Jovian Directorate|Material Institute|Prosper|Shapeset|X-Sense|Khanid Innovation|Khanid Transport|Khanid Works|Royal Khanid Navy|Boundless Creation|Brutor Tribe|Brutor Vanguard|Circle of Huskarl|Core Complexion Inc\.|Eifyr and Co\.|Eyniletti Rangers|Forty-Nine Fedayeen|Freedom Extension|Krullefor Organization|Krusual Covert Operators|Krusual Tribe|Mikramurka Shock Troop|Minmatar Mining Corporation|Native Freshfood|Pator Tech School|Republic Command|Republic Fleet|Republic Justice Department|Republic Military School|Republic Parliament|Republic Security Services|Republic University|Sanmatar Kelkoons|Sebiestor Field Sappers|Sebiestor Tribe|Seykal Expeditionary Group|Six Kin Development|The Leisure Group|Tribal Liberation Force|Tronhadar Free Guard|Urban Management|Vherokior Combat Logistics|Vherokior Tribe|Mordu\'s Legion|Outer Ring Development|Outer Ring Excavations|Outer Ring Prospecting|True Creations|True Power|Serpentis Corporation|Serpentis Inquest|Food Relief|Sisters of EVE|The Sanctuary|InterBus|Society of Conscious Thought|Intaki Bank|Intaki Commerce|Intaki Space Police|Intaki Syndicate|Thukker Mix|Trust Partners|Arkombine)/';
$str = 'Jita IV - Moon 4 - Caldari Navy Assembly Plant
Amarr VIII (Oris) - Emperor Family Academy
Dodixie IX - Moon 20 - Federation Navy Assembly Plant
Hek VIII - Moon 12 - Boundless Creation Factory
Rens VI - Moon 8 - Brutor Tribe Treasury
Mastakomon VI - Propel Dynamics Factory
Ishisomo VIII - Propel Dynamics Factory
Oursulaert III - Federation Navy Testing Facilities
Eruka II - Propel Dynamics Warehouse
Agil VI - Moon 2 - CONCORD Logistic Support
Orvolle I - Federation Navy Assembly Plant
Tash-Murkon Prime II - Moon 1 - Kaalakiota Corporation Factory
Stacmon V - Moon 9 - Federation Navy Assembly Plant
Ichoriya V - Caldari Navy Logistic Support
Motsu VII - Moon 6 - Caldari Navy Logistic Support
X-7OMU II - Moon 7 - The Sanctuary School
Apanake VIII - Moon 8 - Sisters of EVE Bureau
PR-8CA III - Blood Raiders Logistic Support
Teonusude III - Moon 1 - Republic Fleet Assembly Plant
5ZXX-K V - Moon 17 - Mordu\'s Legion Testing Facilities
Vlillirier IV - Moon 13 - Wiyrkomi Corporation Warehouse
TG-Z23 III - Moon 8 - True Power Logistic Support
Tar III - Secure Commerce Commission Depository
Asghatil IX - Moon 3 - DED Assembly Plant
Osmon II - Moon 1 - Sisters of EVE Bureau
Villore VI - Federal Defense Union Logistic Support
Charmerout IX - Wiyrkomi Corporation Factory
Halle VII - Moon 6 - Federal Intelligence Office Assembly Plant
XHQ-7V VI - True Yulai Shipyards
Waskisen IX - Moon 11 - Corporate Police Force Logistic Support
N5Y-4N VII - Moon 20 - Guristas Logistic Support
Badivefi VIII - Moon 10 - Royal Khanid Navy Logistic Support
Kamela V - 24th Imperial Crusade Logistic Support
Esescama VIII - Moon 3 - Imperial Armaments Warehouse
Arnon IX - Moon 3 - Sisters of EVE Bureau
Couster II - Moon 1 - Federal Navy Academy
Clellinon VI - Moon 11 - Center for Advanced Studies School
Maila VII - Expert Housing Warehouse
Aeschee X - Moon 20 - Sisters of EVE Academy
XX9-WV VII - Moon 3 - Salvation Angels Trading Post
Chamemi VI - Moon 1 - Royal Khanid Navy Assembly Plant
Simela IV - Moon 7 - Sisters of EVE Academy
Berta VI - Moon 19 - Ammatar Consulate Bureau
Jita IV - Moon 5 - Caldari Navy Assembly Plant
Nein VII - Moon 4 - Impro Factory
Maila VI - Moon 1 - Zainou Biotech Production
Tintoh VIII - Caldari Navy Testing Facilities
Nourvukaiken V - State Protectorate Logistic Support
Kakakela VI - Moon 15 - Caldari Navy Assembly Plant
Alentene V - Moon 4 - Duvolle Laboratories Factory
Pakkonen IV - Moon 19 - Caldari Constructions Production Plant
Boystin V - Moon 6 - Federal Intelligence Office Assembly Plant
Kamio VI - Moon 7 - Sukuuvestaa Corporation Production Plant
Masalle VI - Moon 9 - Federation Navy Logistic Support
Serpentis Prime VIII - Moon 2 - Serpentis Corporation Chemical Refinery
A-ELE2 VI - Blood Raiders Assembly Plant
Okagaiken IV - Caldari Navy Logistic Support
Vey VIII - Moon 15 - FedMart Warehouse
Alentene VI - Moon 6 - Roden Shipyards Warehouse
Nisuwa VII - State Protectorate Logistic Support
Irjunen II - Corporate Police Force Assembly Plant
Aunia I - Moon 11 - Federation Navy Assembly Plant
Pashanai III - Moon 2 - Amarr Navy Assembly Plant
Illuin V - Moon 13 - Republic University
Sortet V - Moon 1 - Federation Navy Assembly Plant
Bereye VI - Federal Intelligence Office Assembly Plant
Cat VI - Moon 7 - Federal Intelligence Office Logistic Support
Hysera II - Corporate Police Force Assembly Plant
Akiainavas III - School of Applied Knowledge
V-3YG7 VI - The Capital
Uemisaisen VII - Moon 16 - Home Guard Assembly Plant
Ordion VII - Moon 16 - Amarr Navy Testing Facilities
J5A-IX III - Mark Watney flies like Ironman
Huola VI - 24th Imperial Crusade Logistic Support
Algogille IX - Moon 3 - Federal Administration Information Center
Kourmonen V - Ishukone Corporation Factory
Sujarento IV - State Protectorate Logistic Support
SHBF-V VI - atap\'s Hafnium Vault
Nennamaila X - Wiyrkomi Peace Corps Assembly Plant
LGK-VP V - Moon 3 - True Power Assembly Plant
K-QWHE VI - Moon 15 - Serpentis Corporation Chemical Refinery
Uitra VI - Moon 4 - State War Academy
Zinkon VII - Moon 1 - Caldari Business Tribunal Accounting
Kehjari II - Kaalakiota Corporation Factory
Konora VI - Kaalakiota Corporation Factory
YZ-LQL VII - Moon 1 - Guardian Angels Assembly Plant
Kulelen V - Moon 8 - Zainou Biotech Production
Vestouve IX - Moon 11 - Aliastra Warehouse
G-0Q86 VII - Moon 1 - Guardian Angels Assembly Plant
Kinakka III - Lai Dai Corporation Factory
Gehi IX - Moon 4 - Royal Khanid Navy Assembly Plant
Funtanainen IV - Moon 1 - Caldari Navy Logistic Support
Ihakana VIII - Moon 6 - Nugoeihuvi Corporation Development Studio
Oshaima IV - State Protectorate Logistic Support
Shintaht IV (Konrakas) - Asgard I9B-8X
Auvergne V - Moon 5 - Federal Intelligence Office Assembly Plant
Aphend VII - Moon 7 - Carthum Conglomerate Foundry
B-WPLZ VII - The Stables
43B-O1 VIII - 43Bad Titans
5KG-PY II - 20000 Isotopes
Palas II - Royal Khanid Navy Assembly Plant
E02-IK VIII - Moon 1 - Thukker Mix Factory
Sirekur VIII - Moon 1 - Republic University
WW-OVQ VI - District-85 Trade and Sale
Luminaire VII (Caldari Prime) - Moon 6 - Federation Navy Assembly Plant
4C-B7X VIII - Moon 1 - Outer Ring Excavations Mining Outpost
Maila IV - Zainou Biotech Production
Aldrat IX - Moon 13 - Minmatar Mining Corporation Mineral Reserve
Tuomuta III - Ducia Foundry Mining Outpost
Eldjaerin IV - Nurtura Food Packaging
WY-9LL VIII - Moon 3 - Dominations Testing Facilities
J7A-UR VI - Dominations Testing Facilities
Mani VII - Moon 10 - Amarr Navy Assembly Plant
Z3V-1W VII - Blood Raiders Assembly Plant
N-HSK0 IV - Newport Beach
Duripant VII - Moon 6 - Federal Navy Academy
Venilen IX - Moon 7 - Caldari Navy Testing Facilities
D87E-A VII - Moon 16 - Archangels Assembly Plant
P-33KR II - RIP Vile Rat
Sobaseki VII - Caldari Navy Logistic Support
Nakri V - Moon 5 - Sarum Family Assembly Plant
E-FIC0 I - E-FIC0NGESTION
DR-427 VIII - Knackwurst inside
P4-3TJ IX - Puckum\'s house of Handy\'s
Azer VI - Moon 3 - Federation Customs Assembly Plant
Lanngisi III - Moon 2 - Sisters of EVE Bureau
Avenod VIII - Moon 17 - TransStellar Shipping Storage
319-3D IX - Moon 22 - Blood Raiders Logistic Support
Onnamon IV - State Protectorate Logistic Support
Deltole III - Moon 1 - Core Complexion Inc. Warehouse
X-M2LR VI - Moon 8 - Intaki Commerce Warehouse
Dresi I - Moon 18 - Emperor Family Bureau
Onnamon I - State War Academy
Gamis X - Ammatar Fleet Logistic Support
Badivefi VI - Moon 2 - Royal Khanid Navy Logistic Support
C1-HAB IV - Ulthor\'s Manor
Hasmijaala X - Moon 3 - Expert Housing Production Plant
Dumkirinur V - Republic Military School
6T3I-L VII - Moon 5 - Beta HQ
Mora VI - Moon 4 - Ishukone Corporation Factory
XGH-SH VIII - Look who\'s back
Friggi VII - Moon 12 - Lai Dai Corporation Factory
Bhizheba IX - Moon 1 - Amarr Navy Logistic Support
XKM-DE X - Panhellenic project
4-1ECP VIII - Blood-Gulch Outpost Number One
N-8BZ6 IX - The Curse Of Volt
Jufvitte VI - Moon 4 - Roden Shipyards Factory
C8-CHY X - RIP Vile Rat
Akonoinen I - Wiyrkomi Peace Corps Assembly Plant
FC-3YI VII - Ragnar Anchorage
Fliet III - Federal Defense Union Logistic Support
Uemon VIII - Moon 3 - Perkone Factory
Uedama VII - Lai Dai Corporation Factory
Vasala VI - Moon 10 - Genolution Biotech Production
Avele V - Moon 11 - CreoDron Warehouse
I-1QKL VII - Operation Barbarossa
Cistuvaert V - Moon 12 - Center for Advanced Studies School
ERVK-P VII - Scorpio Base
Niballe V - Moon 1 - Federation Navy Testing Facilities
RQNF-9 XI - Bear\'s Den
Halle VII - Federal Administration Bureau Offices
Arnola VII - Moon 1 - Trust Partners Trading Post
Parses VI - Moon 11 - Royal Khanid Navy Assembly Plant
Siseide VII - Expert Distribution Retail Center
Aunsou IV - Moon 3 - Core Complexion Inc. Factory
FZCR-3 I - The Oasis
Zehru IX - Moon 4 - Viziam Factory
Torrinos V - Moon 16 - Home Guard Logistic Support
6VDT-H V - Praesidium
FD-MLJ VII - Moon 2 - Intaki Bank Depository
Bosboger VI - Moon 7 - Republic Security Services Assembly Plant
Piak III - Moon 19 - Caldari Navy Assembly Plant
Ishomilken V - State Protectorate Logistic Support
WV-0R2 V - It won\'t fit
O-O2GN II - Ice Citadel
Kulu X - Moon 16 - Royal Amarr Institute School
1L-OEK VIII - Spectre\'s Cloaky Ninjas
3V8-LJ IV - DOKDO-SUPREMACY
Auner VIII - Moon 10 - Thukker Mix Factory
Muvolailen IX - Moon 11 - Spacelane Patrol Assembly Plant
OP7-BP V - The Tapirs Den
L-1SW8 I - Fort Apache
Tanoo IV - Trust Partners Trading Post
XUW-3X VIII - Shoulder Deep
Gergish X - Moon 3 - Royal Amarr Institute School
M-RPN3 VII - Deeps homeland
DK-FXK V - DK-Favela
VSIG-K VIII - Moon 1 - Intaki Syndicate Bureau
Algogille XIII - Federation Navy Testing Facilities
Oulley IV - Moon 1 - Federation Navy Assembly Plant
Sasta VI - Moon 3 - Ammatar Fleet Assembly Plant
KFIE-Z III - Moon 7 - Blood Raiders Assembly Plant
W0X-MG VI - ManDude - The Mouth Of The North
Kubinen IX - Spacelane Patrol Assembly Plant
Hageken V - Moon 2 - Caldari Navy Assembly Plant
Sivala VIII - Sukuuvestaa Corporation Warehouse
Scheenins II - Moon 2 - Roden Shipyards Factory
Myyhera VIII - Moon 2 - Amarr Constructions Production Plant
HVGR-R V - HVGR-R - MTL Reprocessing Plant
8QMO-E III - RIP Vile Rat
Jouvulen III - Science and Trade Institute School
Arton II - CreoDron Factory
Pemene VI - Moon 2 - Wiyrkomi Corporation Factory
0N-3RO VII - Moon 14 - Blood Raiders Testing Facilities
85-B52 IV - 85-B52s Love Shack
Kisogo VII - State War Academy
Khanid Prime V - Moon 1 - Khanid Innovation Factory
Scolluzer XI - Moon 4 - Nugoeihuvi Corporation Development Studio
NG-M8K III - Tetonic Shift
Aurohunen V - Moon 10 - Propel Dynamics Factory
Penirgman IX - Moon 3 - Ministry of Internal Order Assembly Plant
Sakht VI - Moon 7 - Genolution Biotech Production
E8-432 III - Trust in Patrick
1-7B6D VI - 1-7 SHIME ratting carriers here
HED-GP III - Hatuk Homestead
Uedama VI - Moon 8 - Spacelane Patrol Logistic Support
Esa VIII - Moon 2 - Viziam Warehouse
Sirppala IV - Moon 4 - Rapid Assembly Factory
Hentogaira I - Moon 11 - Science and Trade Institute School
PC9-AY III - Intaki Commerce Trading Post
MB-NKE VII - Word Of Bob
Vlillirier VII - Roden Shipyards Factory
NM-OEA V - Moon 4 - Outer Ring Excavations Mining Outpost
E-YCML IV - Lion\'s Den
0DD-MH VI - Alpha HQ
Nalvula IX - Moon 2 - Spacelane Patrol Assembly Plant
M-MBRT I - Moishe\'s Pawn Shop - we buy gold
O-N589 VIII - Citadel Thugs
60M-TG I - Intergalactic Sparkle Dragon Den
Lirsautton I - CreoDron Factory
Rayl X - Moon 3 - Carthum Conglomerate Factory
9F-7PZ IX - If it aint Dutch It aint much
Eygfe VII - Moon 19 - Minmatar Mining Corporation Refinery
Jel V - Duvolle Laboratories Factory
CH9L-K VI - CH9L-K Milliways
G-D0N3 VIII - Can gD0 attitude
3-SFWG V - DRASY Jobcenter
Shafrak VIII - Moon 9 - Amarr Navy Assembly Plant
Huola X - Moon 2 - Ishukone Corporation Factory
O94U-A I - In Honor of Sean -Vile Rat
Gulfonodi X - Moon 15 - Republic Fleet Testing Facilities
X-7BIX VIII - S E V A S T O P O L
1IX-C0 IX - Carebear Retirement Home
G-4H4C III - Kazeboshka
UVHO-F II - Special Ed Academy
Eha III - State Protectorate Logistic Support
FDZ4-A IX - Moon 6 - Society of Conscious Thought School
DP-JD4 IX - Armistice Station
Ikami X - CreoDron Factory
Villore VII - Moon 6 - Senate Bureau
Tanoo V - Moon 1 - Ammatar Consulate Bureau
NBW-GD VI - ISI\'s Pleasure Palace
H-GKI6 VI - Basilica of Maxentius
Q-ITV5 VI - Sala Alts
Chej VI - Ministry of Internal Order Assembly Plant
Hentogaira II - Perkone Factory
Sasiekko III - 24th Imperial Crusade Logistic Support
0-O6XF IX - Princess of the south
Dresi I - Moon 18 - Republic Security Services Assembly Plant
Tash-Murkon Prime V - Moon 1 - Tash-Murkon Family Bureau
Suroken VIII - Moon 7 - Propel Dynamics Factory
C-BHDN III - Mount Sinai
KZFV-4 IX - FR Liberte Egalite Fraternite
Gisleres IV - Moon 6 - Roden Shipyards Warehouse
Otsela VI - Moon 13 - Ishukone Corporation Factory';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);