import re
regex = re.compile(r"(.+) ([IVXLC]*)(?: \(.+\))? (?:- Moon (\d+) )?- (Doomheim|Pann's Peeps|Polaris Bug Hunters|Polaris Corporation|Polaris Events|24th Imperial Crusade|Amarr Certified News|Amarr Civil Service|Amarr Constructions|Amarr Navy|Amarr Templars|Amarr Trade Registry|Ametat Security|Ardishapur Family|Bragian Order|Carthum Conglomerate|Civic Court|Company of Marcher Lords|Court Chamberlain|Ducia Foundry|Emperor Family|Fraternity of St\. Venefice|Further Foodstuffs|Hedion University|Holdfast Syndicate|HZO Refinery|Imperial Academy|Imperial Armaments|Imperial Chancellor|Imperial Guard|Imperial Shipment|Inherent Implants|Joint Harvesting|Kador Family|Kameira Lodge|Kor-Azor Family|Ministry of Assessment|Ministry of Internal Order|Ministry of War|Noble Appliances|Nurtura|Paladin Survey Force|Red and Silver Hand|Royal Amarr Institute|Royal Uhlans|Sarum Family|Shining Flame|Tal-Romon Legion|Tash-Murkon Family|Theology Council|Viziam|Zoar and Sons|Ammatar Consulate|Ammatar Fleet|Nefantar Miner Association|Archangels|Dominations|Guardian Angels|Salvation Angels|Blood Raiders|Caldari Business Tribunal|Caldari Constructions|Caldari Funds Unlimited|Caldari Navy|Caldari Provisions|Caldari Steel|CBD Corporation|CBD Sell Division|Chief Executive Panel|Commando Perkone|Corporate Police Force|Deep Core Mining Inc\.|Echelon Entertainment|Expert Distribution|Expert Housing|Expert Intervention|Home Guard|House of Records|Hyasyoda Corporation|Ikomari-Onu Enforcement|Intara Direct Action|Internal Security|Ishukone Corporation|Ishukone Watch|Isuuaya Tactical|Kaalakiota Corporation|Kinsho Swords|Kirkinen Risk Control|Lai Dai Corporation|Lai Dai Protection Service|Mercantile Club|Minedrill|Modern Finances|Nugoeihuvi Corporation|Onikanabo Brigade|Osmon Surveillance|Peace and Order Unit|Perkone|Poksu Mineral Group|Prompt Delivery|Propel Dynamics|Rapid Assembly|School of Applied Knowledge|Science and Trade Institute|Seituoda Taskforce Command|Spacelane Patrol|State and Region Bank|State Peacekeepers|State Protectorate|State War Academy|Storm Wind Strikeforce|Sukuuvestaa Corporation|Templis Dragonaurs|Top Down|Wiyrkomi Corporation|Wiyrkomi Peace Corps|Ytiri|Zainou|Zero-G Research Firm|Zumari Force Projection|CONCORD|DED|Inner Circle|Secure Commerce Commission|Vigilant Tyrannos|Algintal Core|Aliastra|Allotek Industries|Astral Mining Inc\.|Bank of Luminaire|Center for Advanced Studies|Chatelain Rapid Response|Chemal Tech|Combined Harvest|Condotta Rouvenor|CreoDron|Crux Special Tasks Group|Duvolle Laboratories|Edimmu Warfighters|Egonics Inc\.|Federal Administration|Federal Defense Union|Federal Freight|Federal Intelligence Office|Federal Marines|Federal Navy Academy|Federation Customs|Federation Navy|FedMart|Garoun Investment Bank|Impetus|Inner Zone Shipping|Kang Lo Directorate|Mannar Focused Warfare|Material Acquisition|Namtar Elite|Ostrakon Agency|Pend Insurance|Poteque Pharmaceuticals|President|Quafe Company|Resheph Interstellar Strategy|Roden Shipyards|Senate|Sinq Laison Gendarmes|Supreme Court|The Scope|TransStellar Shipping|University of Caille|Villore Sec Ops|Guristas|Guristas Production|Academy of Aggressive Behaviour|Genolution|Impro|Jove Navy|Jovian Directorate|Material Institute|Prosper|Shapeset|X-Sense|Khanid Innovation|Khanid Transport|Khanid Works|Royal Khanid Navy|Boundless Creation|Brutor Tribe|Brutor Vanguard|Circle of Huskarl|Core Complexion Inc\.|Eifyr and Co\.|Eyniletti Rangers|Forty-Nine Fedayeen|Freedom Extension|Krullefor Organization|Krusual Covert Operators|Krusual Tribe|Mikramurka Shock Troop|Minmatar Mining Corporation|Native Freshfood|Pator Tech School|Republic Command|Republic Fleet|Republic Justice Department|Republic Military School|Republic Parliament|Republic Security Services|Republic University|Sanmatar Kelkoons|Sebiestor Field Sappers|Sebiestor Tribe|Seykal Expeditionary Group|Six Kin Development|The Leisure Group|Tribal Liberation Force|Tronhadar Free Guard|Urban Management|Vherokior Combat Logistics|Vherokior Tribe|Mordu's Legion|Outer Ring Development|Outer Ring Excavations|Outer Ring Prospecting|True Creations|True Power|Serpentis Corporation|Serpentis Inquest|Food Relief|Sisters of EVE|The Sanctuary|InterBus|Society of Conscious Thought|Intaki Bank|Intaki Commerce|Intaki Space Police|Intaki Syndicate|Thukker Mix|Trust Partners|Arkombine)")
test_str = ("Jita IV - Moon 4 - Caldari Navy Assembly Plant\n"
"Amarr VIII (Oris) - Emperor Family Academy\n"
"Dodixie IX - Moon 20 - Federation Navy Assembly Plant\n"
"Hek VIII - Moon 12 - Boundless Creation Factory\n"
"Rens VI - Moon 8 - Brutor Tribe Treasury\n"
"Mastakomon VI - Propel Dynamics Factory\n"
"Ishisomo VIII - Propel Dynamics Factory\n"
"Oursulaert III - Federation Navy Testing Facilities\n"
"Eruka II - Propel Dynamics Warehouse\n"
"Agil VI - Moon 2 - CONCORD Logistic Support\n"
"Orvolle I - Federation Navy Assembly Plant\n"
"Tash-Murkon Prime II - Moon 1 - Kaalakiota Corporation Factory\n"
"Stacmon V - Moon 9 - Federation Navy Assembly Plant\n"
"Ichoriya V - Caldari Navy Logistic Support\n"
"Motsu VII - Moon 6 - Caldari Navy Logistic Support\n"
"X-7OMU II - Moon 7 - The Sanctuary School\n"
"Apanake VIII - Moon 8 - Sisters of EVE Bureau\n"
"PR-8CA III - Blood Raiders Logistic Support\n"
"Teonusude III - Moon 1 - Republic Fleet Assembly Plant\n"
"5ZXX-K V - Moon 17 - Mordu's Legion Testing Facilities\n"
"Vlillirier IV - Moon 13 - Wiyrkomi Corporation Warehouse\n"
"TG-Z23 III - Moon 8 - True Power Logistic Support\n"
"Tar III - Secure Commerce Commission Depository\n"
"Asghatil IX - Moon 3 - DED Assembly Plant\n"
"Osmon II - Moon 1 - Sisters of EVE Bureau\n"
"Villore VI - Federal Defense Union Logistic Support\n"
"Charmerout IX - Wiyrkomi Corporation Factory\n"
"Halle VII - Moon 6 - Federal Intelligence Office Assembly Plant\n"
"XHQ-7V VI - True Yulai Shipyards\n"
"Waskisen IX - Moon 11 - Corporate Police Force Logistic Support\n"
"N5Y-4N VII - Moon 20 - Guristas Logistic Support\n"
"Badivefi VIII - Moon 10 - Royal Khanid Navy Logistic Support\n"
"Kamela V - 24th Imperial Crusade Logistic Support\n"
"Esescama VIII - Moon 3 - Imperial Armaments Warehouse\n"
"Arnon IX - Moon 3 - Sisters of EVE Bureau\n"
"Couster II - Moon 1 - Federal Navy Academy\n"
"Clellinon VI - Moon 11 - Center for Advanced Studies School\n"
"Maila VII - Expert Housing Warehouse\n"
"Aeschee X - Moon 20 - Sisters of EVE Academy\n"
"XX9-WV VII - Moon 3 - Salvation Angels Trading Post\n"
"Chamemi VI - Moon 1 - Royal Khanid Navy Assembly Plant\n"
"Simela IV - Moon 7 - Sisters of EVE Academy\n"
"Berta VI - Moon 19 - Ammatar Consulate Bureau\n"
"Jita IV - Moon 5 - Caldari Navy Assembly Plant\n"
"Nein VII - Moon 4 - Impro Factory\n"
"Maila VI - Moon 1 - Zainou Biotech Production\n"
"Tintoh VIII - Caldari Navy Testing Facilities\n"
"Nourvukaiken V - State Protectorate Logistic Support\n"
"Kakakela VI - Moon 15 - Caldari Navy Assembly Plant\n"
"Alentene V - Moon 4 - Duvolle Laboratories Factory\n"
"Pakkonen IV - Moon 19 - Caldari Constructions Production Plant\n"
"Boystin V - Moon 6 - Federal Intelligence Office Assembly Plant\n"
"Kamio VI - Moon 7 - Sukuuvestaa Corporation Production Plant\n"
"Masalle VI - Moon 9 - Federation Navy Logistic Support\n"
"Serpentis Prime VIII - Moon 2 - Serpentis Corporation Chemical Refinery\n"
"A-ELE2 VI - Blood Raiders Assembly Plant\n"
"Okagaiken IV - Caldari Navy Logistic Support\n"
"Vey VIII - Moon 15 - FedMart Warehouse\n"
"Alentene VI - Moon 6 - Roden Shipyards Warehouse\n"
"Nisuwa VII - State Protectorate Logistic Support\n"
"Irjunen II - Corporate Police Force Assembly Plant\n"
"Aunia I - Moon 11 - Federation Navy Assembly Plant\n"
"Pashanai III - Moon 2 - Amarr Navy Assembly Plant\n"
"Illuin V - Moon 13 - Republic University\n"
"Sortet V - Moon 1 - Federation Navy Assembly Plant\n"
"Bereye VI - Federal Intelligence Office Assembly Plant\n"
"Cat VI - Moon 7 - Federal Intelligence Office Logistic Support\n"
"Hysera II - Corporate Police Force Assembly Plant\n"
"Akiainavas III - School of Applied Knowledge\n"
"V-3YG7 VI - The Capital\n"
"Uemisaisen VII - Moon 16 - Home Guard Assembly Plant\n"
"Ordion VII - Moon 16 - Amarr Navy Testing Facilities\n"
"J5A-IX III - Mark Watney flies like Ironman\n"
"Huola VI - 24th Imperial Crusade Logistic Support\n"
"Algogille IX - Moon 3 - Federal Administration Information Center\n"
"Kourmonen V - Ishukone Corporation Factory\n"
"Sujarento IV - State Protectorate Logistic Support\n"
"SHBF-V VI - atap's Hafnium Vault\n"
"Nennamaila X - Wiyrkomi Peace Corps Assembly Plant\n"
"LGK-VP V - Moon 3 - True Power Assembly Plant\n"
"K-QWHE VI - Moon 15 - Serpentis Corporation Chemical Refinery\n"
"Uitra VI - Moon 4 - State War Academy\n"
"Zinkon VII - Moon 1 - Caldari Business Tribunal Accounting\n"
"Kehjari II - Kaalakiota Corporation Factory\n"
"Konora VI - Kaalakiota Corporation Factory\n"
"YZ-LQL VII - Moon 1 - Guardian Angels Assembly Plant\n"
"Kulelen V - Moon 8 - Zainou Biotech Production\n"
"Vestouve IX - Moon 11 - Aliastra Warehouse\n"
"G-0Q86 VII - Moon 1 - Guardian Angels Assembly Plant\n"
"Kinakka III - Lai Dai Corporation Factory\n"
"Gehi IX - Moon 4 - Royal Khanid Navy Assembly Plant\n"
"Funtanainen IV - Moon 1 - Caldari Navy Logistic Support\n"
"Ihakana VIII - Moon 6 - Nugoeihuvi Corporation Development Studio\n"
"Oshaima IV - State Protectorate Logistic Support\n"
"Shintaht IV (Konrakas) - Asgard I9B-8X\n"
"Auvergne V - Moon 5 - Federal Intelligence Office Assembly Plant\n"
"Aphend VII - Moon 7 - Carthum Conglomerate Foundry\n"
"B-WPLZ VII - The Stables\n"
"43B-O1 VIII - 43Bad Titans\n"
"5KG-PY II - 20000 Isotopes\n"
"Palas II - Royal Khanid Navy Assembly Plant\n"
"E02-IK VIII - Moon 1 - Thukker Mix Factory\n"
"Sirekur VIII - Moon 1 - Republic University\n"
"WW-OVQ VI - District-85 Trade and Sale\n"
"Luminaire VII (Caldari Prime) - Moon 6 - Federation Navy Assembly Plant\n"
"4C-B7X VIII - Moon 1 - Outer Ring Excavations Mining Outpost\n"
"Maila IV - Zainou Biotech Production\n"
"Aldrat IX - Moon 13 - Minmatar Mining Corporation Mineral Reserve\n"
"Tuomuta III - Ducia Foundry Mining Outpost\n"
"Eldjaerin IV - Nurtura Food Packaging\n"
"WY-9LL VIII - Moon 3 - Dominations Testing Facilities\n"
"J7A-UR VI - Dominations Testing Facilities\n"
"Mani VII - Moon 10 - Amarr Navy Assembly Plant\n"
"Z3V-1W VII - Blood Raiders Assembly Plant\n"
"N-HSK0 IV - Newport Beach\n"
"Duripant VII - Moon 6 - Federal Navy Academy\n"
"Venilen IX - Moon 7 - Caldari Navy Testing Facilities\n"
"D87E-A VII - Moon 16 - Archangels Assembly Plant\n"
"P-33KR II - RIP Vile Rat\n"
"Sobaseki VII - Caldari Navy Logistic Support\n"
"Nakri V - Moon 5 - Sarum Family Assembly Plant\n"
"E-FIC0 I - E-FIC0NGESTION\n"
"DR-427 VIII - Knackwurst inside\n"
"P4-3TJ IX - Puckum's house of Handy's\n"
"Azer VI - Moon 3 - Federation Customs Assembly Plant\n"
"Lanngisi III - Moon 2 - Sisters of EVE Bureau\n"
"Avenod VIII - Moon 17 - TransStellar Shipping Storage\n"
"319-3D IX - Moon 22 - Blood Raiders Logistic Support\n"
"Onnamon IV - State Protectorate Logistic Support\n"
"Deltole III - Moon 1 - Core Complexion Inc. Warehouse\n"
"X-M2LR VI - Moon 8 - Intaki Commerce Warehouse\n"
"Dresi I - Moon 18 - Emperor Family Bureau\n"
"Onnamon I - State War Academy\n"
"Gamis X - Ammatar Fleet Logistic Support\n"
"Badivefi VI - Moon 2 - Royal Khanid Navy Logistic Support\n"
"C1-HAB IV - Ulthor's Manor\n"
"Hasmijaala X - Moon 3 - Expert Housing Production Plant\n"
"Dumkirinur V - Republic Military School\n"
"6T3I-L VII - Moon 5 - Beta HQ\n"
"Mora VI - Moon 4 - Ishukone Corporation Factory\n"
"XGH-SH VIII - Look who's back\n"
"Friggi VII - Moon 12 - Lai Dai Corporation Factory\n"
"Bhizheba IX - Moon 1 - Amarr Navy Logistic Support\n"
"XKM-DE X - Panhellenic project\n"
"4-1ECP VIII - Blood-Gulch Outpost Number One\n"
"N-8BZ6 IX - The Curse Of Volt\n"
"Jufvitte VI - Moon 4 - Roden Shipyards Factory\n"
"C8-CHY X - RIP Vile Rat\n"
"Akonoinen I - Wiyrkomi Peace Corps Assembly Plant\n"
"FC-3YI VII - Ragnar Anchorage\n"
"Fliet III - Federal Defense Union Logistic Support\n"
"Uemon VIII - Moon 3 - Perkone Factory\n"
"Uedama VII - Lai Dai Corporation Factory\n"
"Vasala VI - Moon 10 - Genolution Biotech Production\n"
"Avele V - Moon 11 - CreoDron Warehouse\n"
"I-1QKL VII - Operation Barbarossa\n"
"Cistuvaert V - Moon 12 - Center for Advanced Studies School\n"
"ERVK-P VII - Scorpio Base\n"
"Niballe V - Moon 1 - Federation Navy Testing Facilities\n"
"RQNF-9 XI - Bear's Den\n"
"Halle VII - Federal Administration Bureau Offices\n"
"Arnola VII - Moon 1 - Trust Partners Trading Post\n"
"Parses VI - Moon 11 - Royal Khanid Navy Assembly Plant\n"
"Siseide VII - Expert Distribution Retail Center\n"
"Aunsou IV - Moon 3 - Core Complexion Inc. Factory\n"
"FZCR-3 I - The Oasis\n"
"Zehru IX - Moon 4 - Viziam Factory\n"
"Torrinos V - Moon 16 - Home Guard Logistic Support\n"
"6VDT-H V - Praesidium\n"
"FD-MLJ VII - Moon 2 - Intaki Bank Depository\n"
"Bosboger VI - Moon 7 - Republic Security Services Assembly Plant\n"
"Piak III - Moon 19 - Caldari Navy Assembly Plant\n"
"Ishomilken V - State Protectorate Logistic Support\n"
"WV-0R2 V - It won't fit\n"
"O-O2GN II - Ice Citadel\n"
"Kulu X - Moon 16 - Royal Amarr Institute School\n"
"1L-OEK VIII - Spectre's Cloaky Ninjas\n"
"3V8-LJ IV - DOKDO-SUPREMACY\n"
"Auner VIII - Moon 10 - Thukker Mix Factory\n"
"Muvolailen IX - Moon 11 - Spacelane Patrol Assembly Plant\n"
"OP7-BP V - The Tapirs Den\n"
"L-1SW8 I - Fort Apache\n"
"Tanoo IV - Trust Partners Trading Post\n"
"XUW-3X VIII - Shoulder Deep\n"
"Gergish X - Moon 3 - Royal Amarr Institute School\n"
"M-RPN3 VII - Deeps homeland\n"
"DK-FXK V - DK-Favela\n"
"VSIG-K VIII - Moon 1 - Intaki Syndicate Bureau\n"
"Algogille XIII - Federation Navy Testing Facilities\n"
"Oulley IV - Moon 1 - Federation Navy Assembly Plant\n"
"Sasta VI - Moon 3 - Ammatar Fleet Assembly Plant\n"
"KFIE-Z III - Moon 7 - Blood Raiders Assembly Plant\n"
"W0X-MG VI - ManDude - The Mouth Of The North\n"
"Kubinen IX - Spacelane Patrol Assembly Plant\n"
"Hageken V - Moon 2 - Caldari Navy Assembly Plant\n"
"Sivala VIII - Sukuuvestaa Corporation Warehouse\n"
"Scheenins II - Moon 2 - Roden Shipyards Factory\n"
"Myyhera VIII - Moon 2 - Amarr Constructions Production Plant\n"
"HVGR-R V - HVGR-R - MTL Reprocessing Plant\n"
"8QMO-E III - RIP Vile Rat\n"
"Jouvulen III - Science and Trade Institute School\n\n"
"Arton II - CreoDron Factory\n"
"Pemene VI - Moon 2 - Wiyrkomi Corporation Factory\n"
"0N-3RO VII - Moon 14 - Blood Raiders Testing Facilities\n"
"85-B52 IV - 85-B52s Love Shack\n"
"Kisogo VII - State War Academy\n"
"Khanid Prime V - Moon 1 - Khanid Innovation Factory\n"
"Scolluzer XI - Moon 4 - Nugoeihuvi Corporation Development Studio\n"
"NG-M8K III - Tetonic Shift\n"
"Aurohunen V - Moon 10 - Propel Dynamics Factory\n"
"Penirgman IX - Moon 3 - Ministry of Internal Order Assembly Plant\n"
"Sakht VI - Moon 7 - Genolution Biotech Production\n"
"E8-432 III - Trust in Patrick\n"
"1-7B6D VI - 1-7 SHIME ratting carriers here\n"
"HED-GP III - Hatuk Homestead\n"
"Uedama VI - Moon 8 - Spacelane Patrol Logistic Support\n"
"Esa VIII - Moon 2 - Viziam Warehouse\n"
"Sirppala IV - Moon 4 - Rapid Assembly Factory\n"
"Hentogaira I - Moon 11 - Science and Trade Institute School\n"
"PC9-AY III - Intaki Commerce Trading Post\n"
"MB-NKE VII - Word Of Bob\n"
"Vlillirier VII - Roden Shipyards Factory\n"
"NM-OEA V - Moon 4 - Outer Ring Excavations Mining Outpost\n"
"E-YCML IV - Lion's Den\n"
"0DD-MH VI - Alpha HQ\n"
"Nalvula IX - Moon 2 - Spacelane Patrol Assembly Plant\n"
"M-MBRT I - Moishe's Pawn Shop - we buy gold\n"
"O-N589 VIII - Citadel Thugs\n"
"60M-TG I - Intergalactic Sparkle Dragon Den\n"
"Lirsautton I - CreoDron Factory\n"
"Rayl X - Moon 3 - Carthum Conglomerate Factory\n"
"9F-7PZ IX - If it aint Dutch It aint much\n"
"Eygfe VII - Moon 19 - Minmatar Mining Corporation Refinery\n"
"Jel V - Duvolle Laboratories Factory\n"
"CH9L-K VI - CH9L-K Milliways\n"
"G-D0N3 VIII - Can gD0 attitude\n"
"3-SFWG V - DRASY Jobcenter\n"
"Shafrak VIII - Moon 9 - Amarr Navy Assembly Plant\n"
"Huola X - Moon 2 - Ishukone Corporation Factory\n"
"O94U-A I - In Honor of Sean -Vile Rat\n"
"Gulfonodi X - Moon 15 - Republic Fleet Testing Facilities\n"
"X-7BIX VIII - S E V A S T O P O L\n"
"1IX-C0 IX - Carebear Retirement Home\n"
"G-4H4C III - Kazeboshka\n"
"UVHO-F II - Special Ed Academy\n"
"Eha III - State Protectorate Logistic Support\n"
"FDZ4-A IX - Moon 6 - Society of Conscious Thought School\n"
"DP-JD4 IX - Armistice Station\n"
"Ikami X - CreoDron Factory\n"
"Villore VII - Moon 6 - Senate Bureau\n"
"Tanoo V - Moon 1 - Ammatar Consulate Bureau\n"
"NBW-GD VI - ISI's Pleasure Palace\n"
"H-GKI6 VI - Basilica of Maxentius\n"
"Q-ITV5 VI - Sala Alts\n"
"Chej VI - Ministry of Internal Order Assembly Plant\n"
"Hentogaira II - Perkone Factory\n"
"Sasiekko III - 24th Imperial Crusade Logistic Support\n"
"0-O6XF IX - Princess of the south\n"
"Dresi I - Moon 18 - Republic Security Services Assembly Plant\n"
"Tash-Murkon Prime V - Moon 1 - Tash-Murkon Family Bureau\n"
"Suroken VIII - Moon 7 - Propel Dynamics Factory\n"
"C-BHDN III - Mount Sinai\n"
"KZFV-4 IX - FR Liberte Egalite Fraternite\n"
"Gisleres IV - Moon 6 - Roden Shipyards Warehouse\n"
"Otsela VI - Moon 13 - Ishukone Corporation Factory")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")