#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<a(?:(?!\bhref=)[^>])*>"
Local $sString = "<a href=""></a>" & @CRLF & _
"<a href=""" data-toggle="tab" ></a>" & @CRLF & _
"<a data-toggle="tab" href="foobar"></a>" & @CRLF & _
"<a data-toggle="tab" type=""asdf>test</a>" & @CRLF & _
"<a test="test"></a>" & @CRLF & _
"<a alt="href"></a>" & @CRLF & _
"<a style"newhref"></a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")