$re = '/<a(?:(?!\bhref=)[^>])*>/m';
$str = '<a href=""></a>
<a href=""" data-toggle="tab" ></a>
<a data-toggle="tab" href="foobar"></a>
<a data-toggle="tab" type=""asdf>test</a>
<a test="test"></a>
<a alt="href"></a>
<a style"newhref"></a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);