const regex = /\[link=(?:https?:)?\/\/(www\.)?([\da-z\.-]+)\.([a-z\.]{2,6})([\/\w \.-](\S*[&|#]\S+)*)*\/?\]\S(.*?)\[\/link\]/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[link=(?:https?:)?\\\/\\\/(www\\.)?([\\da-z\\.-]+)\\.([a-z\\.]{2,6})([\\\/\\w \\.-](\\S*[&|#]\\S+)*)*\\\/?\\]\\S(.*?)\\[\\\/link\\]', 'ig')
const str = `// Lolos
[link=https://namablog.com/]teks[/link]
[link=http://namablog.co.id/]teks[/link]
[link=http://namablog.com/2016/04/vita-denique-conferta-voluptatum-omnium.html]teks[/link]
[link=https://namablog.blogspot.com/2016/04/vita-denique-conferta-voluptatum-omnium.html?showComment=1468398368234#c4159204139756303657]teks[/link]
[link=https://namablog.blogspot.co.id/search?updated-max=2016-04-17T04:28:00-07:00&max-results=7/]teks[/link]
// Lolos tanpa protokol
[link=//namablog.com/]teks[/link]
// Tidak lolos tanpa teks
[link=https://namablog.com][/link]
// Tidak lolos jika hanya spasi
[link=https://namablog.com] [/link]
// Format rusak, tidak lolos!
[link=https://namablog.com/]teks[/link
[link=https://namablog]teks[link]
[link=https://namablog.com/]teks/link]
[link=https://namablog.com/]teks[link]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}