# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[link=(?:https?:)?\/\/(www\.)?([\da-z\.-]+)\.([a-z\.]{2,6})([\/\w \.-](\S*[&|#]\S+)*)*\/?\]\S(.*?)\[\/link\]"
test_str = ("// Lolos\n"
"[link=https://namablog.com/]teks[/link]\n"
"[link=http://namablog.co.id/]teks[/link]\n"
"[link=http://namablog.com/2016/04/vita-denique-conferta-voluptatum-omnium.html]teks[/link]\n"
"[link=https://namablog.blogspot.com/2016/04/vita-denique-conferta-voluptatum-omnium.html?showComment=1468398368234#c4159204139756303657]teks[/link]\n"
"[link=https://namablog.blogspot.co.id/search?updated-max=2016-04-17T04:28:00-07:00&max-results=7/]teks[/link]\n\n"
"// Lolos tanpa protokol\n"
"[link=//namablog.com/]teks[/link]\n\n"
"// Tidak lolos tanpa teks\n"
"[link=https://namablog.com][/link]\n"
"// Tidak lolos jika hanya spasi\n"
"[link=https://namablog.com] [/link]\n\n"
"// Format rusak, tidak lolos!\n"
"[link=https://namablog.com/]teks[/link\n"
"[link=https://namablog]teks[link]\n"
"[link=https://namablog.com/]teks/link]\n"
"[link=https://namablog.com/]teks[link]")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.