package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.{0,16}$`)
var str = `1234567890123456
123
1234567890123456678
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}