$re = '/^.{0,16}$/m';
$str = '1234567890123456
123
1234567890123456678
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);