$re = '/(?=(\w+)(?=\w* \w*?\1))\w/mi';
$str = 'maxs maxmuster
Mymaxmuis maxmuster
Lemu maxmuster
muster maxmuster';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);