re = /(?=(\w+)(?=\w* \w*?\1))\w/mi
str = 'maxs maxmuster
Mymaxmuis maxmuster
Lemu maxmuster
muster maxmuster'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end