const regex = /"\\?([\w ]+)(?=\.exe)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"\\\\?([\\w ]+)(?=\\.exe)', 'gm')
const str = `Send('BLA.CMD "Testasdf.exe" folder\\file.txt asdf123')
Send('{enter}')
ShellExecute(@ScriptDir & "\\folder\\file.txt")
ShellExecute(@HomeDrive & "\\Program Files\\PROGRAMDIR\\Program Dir\\my program.exe", @ScriptDir & "\\Testblabla.exe")`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}