re = /"\\?([\w ]+)(?=\.exe)/m
str = 'Send(\'BLA.CMD "Testasdf.exe" folder\\file.txt asdf123\')
Send(\'{enter}\')
ShellExecute(@ScriptDir & "\\folder\\file.txt")
ShellExecute(@HomeDrive & "\\Program Files\\PROGRAMDIR\\Program Dir\\my program.exe", @ScriptDir & "\\Testblabla.exe")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end