import Foundation
let pattern = #"^0(?:\R(?!\R)|.)*?\b(?:kryptonite|stalagmite)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
00:20314 lorem ipsum
want this
kryptonite
00:02314 quux
padding
dont want this
00:03124 foo
neither this
00:01324 foo
but we want this
stalagmite
00:02134 tralala
not this
00:03124 bar foo
and we want this
kryptonite but not this(!)
00:02134 foo bar
and not this either
00:01234 dolor sit amet
EOF
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)