package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/([a-zA-Z0-9]+[-]{1})*[a-zA-Z0-9]+$`)
var str = `/cheers-summer-camp-contest-winners`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}