re = /^\/([a-zA-Z0-9]+[-]{1})*[a-zA-Z0-9]+$/m
str = '/cheers-summer-camp-contest-winners'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end