using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(0|(\+[0-9]{2}[. -]?))[1-9]([. -]?[0-9][0-9]){4}$";
string input = @"+33 632841181";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}