package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(0|(\+[0-9]{2}[. -]?))[1-9]([. -]?[0-9][0-9]){4}$`)
var str = `+33 632841181`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}