import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\bONLY\\h+)(.+)(\\R.*?fk)_\\S+(.+?\\bREFERENCES\\h+)([^(]+)";
final String string = "ALTER TABLE ONLY document_labels\n"
+ "ADD CONSTRAINT fk_g71qgs6l2ufr3170u44j5fpk3 FOREIGN KEY (label_id) REFERENCES application_value(id);\n"
+ "ALTER TABLE ONLY rule_group_functionality_mapping\n"
+ "ADD CONSTRAINT fk_g8twyunj9bm096sqywdi8rcx8 FOREIGN KEY (rule_group) REFERENCES application_value(id);\n"
+ "ALTER TABLE ONLY time_track\n"
+ "ADD CONSTRAINT fk_gmpyguqbpm1ndjjsxvt03wq4g FOREIGN KEY (user_id) REFERENCES user_account(user_id);";
final String subst = "$1$2$3_$2_$5$4$5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}