import re
regex = re.compile(r"(\bONLY\h+)(.+)(\R.*?fk)_\S+(.+?\bREFERENCES\h+)([^(]+)")
test_str = ("ALTER TABLE ONLY document_labels\n"
"ADD CONSTRAINT fk_g71qgs6l2ufr3170u44j5fpk3 FOREIGN KEY (label_id) REFERENCES application_value(id);\n"
"ALTER TABLE ONLY rule_group_functionality_mapping\n"
"ADD CONSTRAINT fk_g8twyunj9bm096sqywdi8rcx8 FOREIGN KEY (rule_group) REFERENCES application_value(id);\n"
"ALTER TABLE ONLY time_track\n"
"ADD CONSTRAINT fk_gmpyguqbpm1ndjjsxvt03wq4g FOREIGN KEY (user_id) REFERENCES user_account(user_id);")
subst = "$1$2$3_$2_$5$4$5"
result = regex.sub(subst, test_str)
if result:
print(result)